Mir fehlt was im Objekteditor

  • Ich glaube, dass mir was im Objekteditor fehlt. Ich wollte bei einem Gebäude die Bepflanzung ändern und habe es dafür im Objekteditor geladen. Aber was mussten meine erstaunten Augen feststellen? Die Menü-/Werkzeugleiste am unteren Bildschirmrand ist nicht da!


    Das war gestern schon so, vielleicht noch länger, aber ich habe schon lange nicht mehr den Editor geöffnet gehabt. Der Karteneditor funktioniert hingegen fast einwandfrei.

    Ist jemanden das Problem bekannt? Ich vermute, dass wie sooft eine MOD dahintersteckt. Aber welche?


    Über Hilfe würde ich mich sehr freuen.


    Mit freundlichen Grüßen,


    Gaumefreude


    (und schönen Sonntag noch ihr Pappnasen!:D)

    Meine Mutter sagte: "Wenn du weiter so viel vorm PC hockst, dann schicke ich dich in's Heim!". Tja, ich habe weiter gezockt und so bin ich im Spielerheim gelandet.

  • Danke Sunshine1971 ! Hab RICO deaktiviert und jetzt funktioniert der Editor wieder. Keine Ahnung warum der den Editor so beeinflusst :hmm:. Wollte jetzt das Gebäude in der Stadt bauen aber das Spiel ist abgestürzt und ich hab vergessen RICO wieder anzuschalten:dash:. Aber nochmals danke für die schnelle Hilfe!:thumbup:

    Meine Mutter sagte: "Wenn du weiter so viel vorm PC hockst, dann schicke ich dich in's Heim!". Tja, ich habe weiter gezockt und so bin ich im Spielerheim gelandet.

  • Es gibt eine viel bessere Abhilfe, das Problem mit den diversen Editoren, ob nun der Karten-Editor, Themen-Editor, Objekt-Editor oder der Szenario-Editor, das Problem sind die Programmierer der Mods, denn man muss eins wissen, ein Asset, egal von welchen Typ wird dem Spiel kaum Probleme bereiten, außer eventuelle Anzeigefehler die aber dann dem 3D-Objekt zu schulden sind, bei Mods sieht das anders aus, es gibt unterschiedliche Mods.


    Mods sind kleine Mini-Programme, Funktions-Erweiterungen oder komplett überarbeitete Programm-Routinen, das Spiel stellt für Mods diverse Schnittstellen zur Verfügung, aber warum nehmen Mods nun so viel Einfluss auf die Editoren, fast alle Editoren laden halt die Spielwelt, nur das diese halt meistens Leer ist, und andere Funktionen bereitstellt als wenn man eine Stadt spielt und das ist der Punkt der halt bei diversen Mods zu Probleme führt, es gibt halt Mods die auf Funktionen oder Routinen zugreifen wollen die aber im Editor-Modus nicht bereitstehen, somit funktioniert die Mod nicht und das Spiel stürzt ab oder es kommt zu Fehlfunktionen.


    Möchte man nun Mods nicht ständig deaktivieren um im Editor eine neue Karte, Autobahnkreuz, oder ein anderes Objekt erstellen, sollte man das Spiel mit dem Parameter "--disableMods" starten, wie das ganze funktioniert und sogar noch eleganter möglich ist, erfährt man hier

    Mainboard : MSI X99A XPower AC

    CPU : Intel Core I7-5930K

    Arbeitsspeicher : G.Skill F4-2400C15Q2-64GRK (nur mit 32 GByte in verwendung)

    Grafikkarte : MSI GForce GTX-970 Gaming 4G

    Betriebssystem : Windows 10 Pro

    Programme: Blender 2.90/2.91x, GIMP 2.10, Word & Excel

  • Ah, an RICO liegt's.. darauf hätte ich als letztes getippt, ich habe das Problem nämlich auch. Das scheint aber erst seit einem Update vor ein paar Wochen so zu sein, denn RICO nutze ich schon ewig und hatte vorher keine Probleme im Editor.

    In Cities:Skylines hält die alte WoW-Regel eindrucksvoll wieder Einzug: "don't play on patchday patchweek!"


    Core i-5 7600k - 32 GB DDR4-2400 - GTX 1060 6GB - Win 10 64 Bit